aboutsummaryrefslogtreecommitdiff
path: root/docker.nix
diff options
context:
space:
mode:
Diffstat (limited to 'docker.nix')
-rw-r--r--docker.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/docker.nix b/docker.nix
index 0cd64856f..ddf6feff5 100644
--- a/docker.nix
+++ b/docker.nix
@@ -4,6 +4,8 @@
, tag ? "latest"
, channelName ? "nixpkgs"
, channelURL ? "https://nixos.org/channels/nixpkgs-unstable"
+, extraPkgs ? []
+, maxLayers ? 100
}:
let
defaultPkgs = with pkgs; [
@@ -23,7 +25,7 @@ let
iana-etc
git
openssh
- ];
+ ] ++ extraPkgs;
users = {
@@ -229,7 +231,7 @@ let
in
pkgs.dockerTools.buildLayeredImageWithNixDb {
- inherit name tag;
+ inherit name tag maxLayers;
contents = [ baseSystem ];