diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 9 |
1 files changed, 3 insertions, 6 deletions
@@ -87,6 +87,7 @@ crossSystems = [ "armv6l-linux" "armv7l-linux" + "riscv64-linux" # FIXME: still broken in 24.05: fails to build rustc(??) due to missing -lstdc++ dep # "x86_64-freebsd" # FIXME: broken dev shell due to python @@ -151,8 +152,6 @@ } ); - binaryTarball = nix: pkgs: pkgs.callPackage ./nix-support/binary-tarball.nix { inherit nix; }; - overlayFor = getStdenv: final: prev: let @@ -235,13 +234,11 @@ ); # Perl bindings for various platforms. - perlBindings = forAllSystems (system: nixpkgsFor.${system}.native.nix.perl-bindings); + perlBindings = forAllSystems (system: nixpkgsFor.${system}.native.nix.passthru.perl-bindings); # Binary tarball for various platforms, containing a Nix store # with the closure of 'nix' package. - binaryTarball = forAllSystems ( - system: binaryTarball nixpkgsFor.${system}.native.nix nixpkgsFor.${system}.native - ); + binaryTarball = forAllSystems (system: nixpkgsFor.${system}.native.nix.passthru.binaryTarball); # docker image with Lix inside dockerImage = lib.genAttrs linux64BitSystems (system: self.packages.${system}.dockerImage); |