aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index f3a401868..1707c53b8 100644
--- a/flake.nix
+++ b/flake.nix
@@ -701,7 +701,10 @@
outputs = [ "out" "dev" "doc" ];
- nativeBuildInputs = nativeBuildDeps ++ [ clang-tools bear ];
+ nativeBuildInputs = nativeBuildDeps
+ ++ (lib.optionals
+ nixpkgsFor.${system}.${stdenv}.cc.isClang
+ [ bear clang-tools ]);
buildInputs = buildDeps ++ propagatedDeps ++ awsDeps;
inherit configureFlags;