aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 96823a997..2dcdc28fa 100644
--- a/flake.nix
+++ b/flake.nix
@@ -354,6 +354,8 @@
name = "nix-build";
src = self.hydraJobs.tarball;
+ enableParallelBuilding = true;
+
buildInputs = buildDeps;
dontInstall = false;
@@ -366,6 +368,9 @@
# syntax-check generated dot files, it still requires some
# fonts. So provide those.
FONTCONFIG_FILE = texFunctions.fontsConf;
+
+ # To test building without precompiled headers.
+ makeFlagsArray = [ "PRECOMPILE_HEADERS=0" ];
};
# System tests.