aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index c160daed9..662469479 100644
--- a/flake.nix
+++ b/flake.nix
@@ -282,6 +282,10 @@
# cheaper x86_64-linux compute in CI.
# It is clangStdenv because clang's sanitizers are nicer.
asanBuild = self.packages.x86_64-linux.nix-clangStdenv.override {
+ # Improve caching of non-code changes by not changing the
+ # derivation name every single time, since this will never be seen
+ # by users anyway.
+ versionSuffix = "";
sanitize = [
"address"
"undefined"
@@ -310,6 +314,17 @@
touch $out
'';
+ # clang-tidy run against the Lix codebase using the Lix clang-tidy plugin
+ clang-tidy =
+ let
+ nixpkgs = nixpkgsFor.x86_64-linux.native;
+ inherit (nixpkgs) pkgs;
+ in
+ pkgs.callPackage ./package.nix {
+ versionSuffix = "";
+ lintInsteadOfBuild = true;
+ };
+
# Make sure that nix-env still produces the exact same result
# on a particular version of Nixpkgs.
evalNixpkgs =