aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix43
1 files changed, 32 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index a707e90e7..a50533a29 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,8 +2,9 @@
description = "The purely functional package manager";
inputs.nixpkgs.url = "nixpkgs/nixos-20.03-small";
+ inputs.lowdown-src = { url = "github:edolstra/lowdown/no-structs-in-anonymous-unions"; flake = false; };
- outputs = { self, nixpkgs }:
+ outputs = { self, nixpkgs, lowdown-src }:
let
@@ -62,10 +63,8 @@
buildDeps =
[ bison
flex
- libxml2
- libxslt
- docbook5
- docbook_xsl_ns
+ mdbook
+ lowdown
autoconf-archive
autoreconfHook
@@ -74,9 +73,6 @@
openssl pkgconfig sqlite
libarchive
boost
- (if lib.versionAtLeast lib.version "20.03pre"
- then nlohmann_json
- else nlohmann_json.override { multipleHeaders = true; })
nlohmann_json
# Tests
@@ -172,6 +168,7 @@
pkgconfig
pkgs.perl
boost
+ nlohmann_json
]
++ lib.optional (stdenv.isLinux || stdenv.isDarwin) libsodium;
@@ -187,6 +184,30 @@
};
+ lowdown = with final; stdenv.mkDerivation {
+ name = "lowdown-0.7.1";
+
+ /*
+ src = fetchurl {
+ url = https://kristaps.bsd.lv/lowdown/snapshots/lowdown-0.7.1.tar.gz;
+ hash = "sha512-1daoAQfYD0LdhK6aFhrSQvadjc5GsSPBZw0fJDb+BEHYMBLjqiUl2A7H8N+l0W4YfGKqbsPYSrCy4vct+7U6FQ==";
+ };
+ */
+
+ src = lowdown-src;
+
+ outputs = [ "out" "dev" ];
+
+ buildInputs = [ which ];
+
+ configurePhase =
+ ''
+ ./configure \
+ PREFIX=${placeholder "dev"} \
+ BINDIR=${placeholder "out"}/bin
+ '';
+ };
+
};
hydraJobs = {
@@ -421,6 +442,8 @@
stdenv.mkDerivation {
name = "nix";
+ outputs = [ "out" "dev" "doc" ];
+
buildInputs = buildDeps ++ propagatedDeps ++ perlDeps;
inherit configureFlags;
@@ -431,11 +454,9 @@
shellHook =
''
- export prefix=$(pwd)/inst
- configureFlags+=" --prefix=$prefix"
- PKG_CONFIG_PATH=$prefix/lib/pkgconfig:$PKG_CONFIG_PATH
PATH=$prefix/bin:$PATH
unset PYTHONPATH
+ export MANPATH=$out/share/man:$MANPATH
'';
});