aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix23
1 files changed, 20 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 31d7f1fcf..0325f33b1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -82,7 +82,9 @@
});
configureFlags =
- lib.optionals stdenv.isLinux [
+ [
+ "CXXFLAGS=-I${lib.getDev rapidcheck}/extras/gtest/include"
+ ] ++ lib.optionals stdenv.isLinux [
"--with-boost=${boost}/lib"
"--with-sandbox-shell=${sh}/bin/busybox"
]
@@ -116,6 +118,7 @@
boost
lowdown-nix
gtest
+ rapidcheck
]
++ lib.optionals stdenv.isLinux [libseccomp]
++ lib.optional (stdenv.isLinux || stdenv.isDarwin) libsodium
@@ -128,9 +131,14 @@
});
propagatedDeps =
- [ (boehmgc.override {
+ [ ((boehmgc.override {
enableLargeConfig = true;
+ }).overrideAttrs(o: {
+ patches = (o.patches or []) ++ [
+ ./boehmgc-coroutine-sp-fallback.diff
+ ];
})
+ )
nlohmann_json
];
};
@@ -469,6 +477,10 @@
src = self;
+ configureFlags = [
+ "CXXFLAGS=-I${lib.getDev pkgs.rapidcheck}/extras/gtest/include"
+ ];
+
enableParallelBuilding = true;
nativeBuildInputs = nativeBuildDeps;
@@ -635,6 +647,7 @@
inherit system crossSystem;
overlays = [ self.overlays.default ];
};
+ inherit (nixpkgsCross) lib;
in with commonDeps { pkgs = nixpkgsCross; }; nixpkgsCross.stdenv.mkDerivation {
name = "nix-${version}";
@@ -647,7 +660,11 @@
nativeBuildInputs = nativeBuildDeps;
buildInputs = buildDeps ++ propagatedDeps;
- configureFlags = [ "--sysconfdir=/etc" "--disable-doc-gen" ];
+ configureFlags = [
+ "CXXFLAGS=-I${lib.getDev nixpkgsCross.rapidcheck}/extras/gtest/include"
+ "--sysconfdir=/etc"
+ "--disable-doc-gen"
+ ];
enableParallelBuilding = true;