aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix43
1 files changed, 16 insertions, 27 deletions
diff --git a/flake.nix b/flake.nix
index f991e4d46..d3033ca05 100644
--- a/flake.nix
+++ b/flake.nix
@@ -531,36 +531,25 @@
devShells = let
makeShell = pkgs: stdenv:
let
- canRunInstalled = stdenv.buildPlatform.canExecute stdenv.hostPlatform;
+ nix = pkgs.callPackage ./package.nix {
+ inherit stdenv versionSuffix fileset;
+ boehmgc = pkgs.boehmgc-nix;
+ busybox-sandbox-shell = pkgs.busybox-sandbox-shell or pkgs.default-busybox-sandbox;
+ };
in
- with commonDeps { inherit pkgs; };
- stdenv.mkDerivation {
- name = "nix";
-
- outputs = [ "out" "dev" "doc" ];
-
- nativeBuildInputs = nativeBuildDeps
- ++ lib.optional (stdenv.cc.isClang && !stdenv.buildPlatform.isDarwin) pkgs.buildPackages.bear
- ++ lib.optional
- (stdenv.cc.isClang && stdenv.hostPlatform == stdenv.buildPlatform)
- pkgs.buildPackages.clang-tools
- # We want changelog-d in the shell even if the current build doesn't need it
- ++ lib.optional (officialRelease || ! buildUnreleasedNotes) changelog-d
- ;
-
- buildInputs = buildDeps ++ propagatedDeps
- ++ awsDeps ++ checkDeps ++ internalApiDocsDeps;
+ nix.overrideAttrs (prev: {
+ nativeBuildInputs = prev.nativeBuildInputs
+ ++ lib.optional (stdenv.cc.isClang && !stdenv.buildPlatform.isDarwin) pkgs.buildPackages.bear
+ ++ lib.optional
+ (stdenv.cc.isClang && stdenv.hostPlatform == stdenv.buildPlatform)
+ pkgs.buildPackages.clang-tools;
- configureFlags = configureFlags
- ++ testConfigureFlags ++ internalApiDocsConfigureFlags
- ++ lib.optional (!canRunInstalled) "--disable-doc-gen";
+ src = null;
- enableParallelBuilding = true;
+ installFlags = "sysconfdir=$(out)/etc";
+ strictDeps = false;
- installFlags = "sysconfdir=$(out)/etc";
-
- shellHook =
- ''
+ shellHook = ''
PATH=$prefix/bin:$PATH
unset PYTHONPATH
export MANPATH=$out/share/man:$MANPATH
@@ -568,7 +557,7 @@
# Make bash completion work.
XDG_DATA_DIRS+=:$out/share
'';
- };
+ });
in
forAllSystems (system:
let