aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build22
1 files changed, 9 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index f89f5a016..7a5f28d6b 100644
--- a/meson.build
+++ b/meson.build
@@ -47,12 +47,12 @@
# in the build directory.
project('lix', 'cpp', 'rust',
+ meson_version : '>=1.4.0',
version : run_command('bash', '-c', 'echo -n $(jq -r .version < ./version.json)$VERSION_SUFFIX', check : true).stdout().strip(),
default_options : [
- 'cpp_std=c++2a',
+ 'cpp_std=c++23',
'rust_std=2021',
- # TODO(Qyriad): increase the warning level
- 'warning_level=1',
+ 'warning_level=2',
'debug=true',
'optimization=2',
'errorlogs=true', # Please print logs for tests that fail
@@ -484,6 +484,7 @@ add_project_arguments(
# TODO(Qyriad): Yes this is how the autoconf+Make system did it.
# It would be nice for our headers to be idempotent instead.
'-include', 'config.h',
+ '-Wno-unused-parameter',
'-Wno-deprecated-declarations',
'-Wimplicit-fallthrough',
'-Werror=switch',
@@ -492,12 +493,6 @@ add_project_arguments(
'-Wdeprecated-copy',
'-Wignored-qualifiers',
'-Werror=suggest-override',
- # Enable assertions in libstdc++ by default. Harmless on libc++. Benchmarked
- # at ~1% overhead in `nix search`.
- #
- # FIXME: remove when we get meson 1.4.0 which will default this to on for us:
- # https://mesonbuild.com/Release-notes-for-1-4-0.html#ndebug-setting-now-controls-c-stdlib-assertions
- '-D_GLIBCXX_ASSERTIONS=1',
language : 'cpp',
)
@@ -593,10 +588,10 @@ run_command(
)
if is_darwin
- configure_file(
- input : 'misc/launchd/org.nixos.nix-daemon.plist.in',
- output : 'org.nixos.nix-daemon.plist',
- copy : true,
+ fs.copyfile(
+ 'misc/launchd/org.nixos.nix-daemon.plist.in',
+ 'org.nixos.nix-daemon.plist',
+ install : true,
install_dir : prefix / 'Library/LaunchDaemons',
)
endif
@@ -612,6 +607,7 @@ endif
if enable_tests
subdir('tests/unit')
subdir('tests/functional')
+ subdir('tests/functional2')
endif
subdir('meson/clang-tidy')