aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index e6151e0a2..0cb2030e7 100644
--- a/meson.build
+++ b/meson.build
@@ -287,6 +287,14 @@ gtest = [
toml11 = dependency('toml11', version : '>=3.7.0', required : true, method : 'cmake')
+pegtl = dependency(
+ 'pegtl',
+ version : '>=3.2.7',
+ required : true,
+ method : 'cmake',
+ modules : [ 'taocpp::pegtl' ],
+)
+
nlohmann_json = dependency('nlohmann_json', required : true)
# lix-doc is a Rust project provided via buildInputs and unfortunately doesn't have any way to be detected.
@@ -335,8 +343,6 @@ endif
# that busybox sh won't run busybox applets as builtins (which would break our sandbox).
lsof = find_program('lsof', native : true)
-bison = find_program('bison', native : true)
-flex = find_program('flex', native : true)
# This is how Nix does generated headers...
# other instances of header generation use a very similar command.