aboutsummaryrefslogtreecommitdiff
path: root/misc/clangbuildanalyzer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'misc/clangbuildanalyzer.nix')
-rw-r--r--misc/clangbuildanalyzer.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/misc/clangbuildanalyzer.nix b/misc/clangbuildanalyzer.nix
deleted file mode 100644
index d73fa8bbb..000000000
--- a/misc/clangbuildanalyzer.nix
+++ /dev/null
@@ -1,33 +0,0 @@
-# Upstreaming here, can be deleted once it's upstreamed:
-# https://github.com/NixOS/nixpkgs/pull/297102
-{
- stdenv,
- lib,
- cmake,
- fetchFromGitHub,
-}:
-stdenv.mkDerivation (finalAttrs: {
- pname = "clangbuildanalyzer";
- version = "1.5.0";
-
- src = fetchFromGitHub {
- owner = "aras-p";
- repo = "ClangBuildAnalyzer";
- rev = "v${finalAttrs.version}";
- sha256 = "sha256-kmgdk634zM0W0OoRoP/RzepArSipa5bNqdVgdZO9gxo=";
- };
-
- nativeBuildInputs = [ cmake ];
-
- meta = {
- description = "Tool for analyzing Clang's -ftrace-time files";
- homepage = "https://github.com/aras-p/ClangBuildAnalyzer";
- maintainers = with lib.maintainers; [ lf- ];
- license = lib.licenses.unlicense;
- platforms = lib.platforms.unix;
- # `long long int` != `size_t`
- # There's no convenient lib.platforms.32bit or anything, but it's easy enough to do ourselves.
- badPlatforms = lib.filter (plat: (lib.systems.elaborate plat).is32bit) lib.platforms.all;
- mainProgram = "ClangBuildAnalyzer";
- };
-})