aboutsummaryrefslogtreecommitdiff
path: root/misc/clangbuildanalyzer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'misc/clangbuildanalyzer.nix')
-rw-r--r--misc/clangbuildanalyzer.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/misc/clangbuildanalyzer.nix b/misc/clangbuildanalyzer.nix
index a317e5144..cee8a0d77 100644
--- a/misc/clangbuildanalyzer.nix
+++ b/misc/clangbuildanalyzer.nix
@@ -1,6 +1,11 @@
# Upstreaming here, can be deleted once it's upstreamed:
# https://github.com/NixOS/nixpkgs/pull/297102
-{ stdenv, lib, cmake, fetchFromGitHub }:
+{
+ stdenv,
+ lib,
+ cmake,
+ fetchFromGitHub,
+}:
stdenv.mkDerivation (finalAttrs: {
pname = "clangbuildanalyzer";
version = "1.5.0";
@@ -12,9 +17,7 @@ stdenv.mkDerivation (finalAttrs: {
sha256 = "sha256-kmgdk634zM0W0OoRoP/RzepArSipa5bNqdVgdZO9gxo=";
};
- nativeBuildInputs = [
- cmake
- ];
+ nativeBuildInputs = [ cmake ];
meta = {
description = "Tool for analyzing Clang's -ftrace-time files";