aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/package.nix b/package.nix
index 6251b28ba..283a590c1 100644
--- a/package.nix
+++ b/package.nix
@@ -449,7 +449,10 @@ stdenv.mkDerivation (finalAttrs: {
shellHook = ''
# don't re-run the hook in (other) nested nix-shells
function lixShellHook() {
- if [[ $name != lix-shell-env ]]; then
+ # n.b. how the heck does this become -env-env? well, `nix develop` does it:
+ # https://git.lix.systems/lix-project/lix/src/commit/7575db522e9008685c4009423398f6900a16bcce/src/nix/develop.cc#L240-L241
+ # this is, of course, absurd.
+ if [[ $name != lix-shell-env && $name != lix-shell-env-env ]]; then
return;
fi