aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/package.nix b/package.nix
index 9c108308d..91ee6b15f 100644
--- a/package.nix
+++ b/package.nix
@@ -70,8 +70,6 @@
# `boehmgc-nix` then this will almost certainly have duplicate patches, which means
# the patches won't apply and we'll get a build failure.
./boehmgc-coroutine-sp-fallback.diff
- # https://github.com/ivmai/bdwgc/pull/586
- ./boehmgc-traceable_allocator-public.diff
];
};
@@ -439,9 +437,14 @@ stdenv.mkDerivation (finalAttrs: {
# For Meson to find Boost.
env = finalAttrs.env;
- # I guess this is necessary because mesonFlags to mkDerivation doesn't propagate in inputsFrom,
- # which only propagates stuff set in hooks? idk.
- inherit (finalAttrs) mesonFlags;
+ mesonFlags =
+ # I guess this is necessary because mesonFlags to mkDerivation doesn't propagate in inputsFrom,
+ # which only propagates stuff set in hooks? idk.
+ finalAttrs.mesonFlags
+ # Clangd breaks when GCC is using precompiled headers, so for the devshell specifically
+ # we make precompiled C++ stdlib conditional on using Clang.
+ # https://git.lix.systems/lix-project/lix/issues/374
+ ++ [ (lib.mesonBool "enable-pch-std" stdenv.cc.isClang) ];
packages =
lib.optional (stdenv.cc.isClang && hostPlatform == buildPlatform) clang-tools_llvm