aboutsummaryrefslogtreecommitdiff
path: root/perl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'perl/meson.build')
-rw-r--r--perl/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/perl/meson.build b/perl/meson.build
index 4b179da8f..b542f3e8a 100644
--- a/perl/meson.build
+++ b/perl/meson.build
@@ -1,5 +1,5 @@
project('lix-perl', 'cpp',
- version : run_command('bash', '-c', 'echo -n $(cat ../.version)$VERSION_SUFFIX', check : true).stdout().strip(),
+ version : run_command('bash', '-c', 'echo -n $(jq -r .version < ../version.json)$VERSION_SUFFIX', check : true).stdout().strip(),
default_options : [
'cpp_std=c++2a',
# TODO(Qyriad): increase the warning level