aboutsummaryrefslogtreecommitdiff
path: root/release-common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'release-common.nix')
-rw-r--r--release-common.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/release-common.nix b/release-common.nix
index de5af452c..f9df6fab9 100644
--- a/release-common.nix
+++ b/release-common.nix
@@ -1,7 +1,9 @@
{ pkgs }:
rec {
- sh = pkgs.busybox.override {
+ # Use "busybox-sandbox-shell" if present,
+ # if not (legacy) fallback and hope it's sufficient.
+ sh = pkgs.busybox-sandbox-shell or (pkgs.busybox.override {
useMusl = true;
enableStatic = true;
enableMinimal = true;
@@ -23,7 +25,7 @@ rec {
CONFIG_ASH_PRINTF y
CONFIG_ASH_TEST y
'';
- };
+ });
configureFlags =
[ "--disable-init-state"