aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix29
1 files changed, 11 insertions, 18 deletions
diff --git a/release.nix b/release.nix
index c602b3da6..6fab352b2 100644
--- a/release.nix
+++ b/release.nix
@@ -25,7 +25,7 @@ let
buildInputs =
[ curl bison flex perl libxml2 libxslt bzip2 xz
- dblatex (dblatex.tex or tetex) nukeReferences pkgconfig sqlite libsodium
+ pkgconfig sqlite libsodium
docbook5 docbook5_xsl
] ++ lib.optional (!lib.inNixShell) git;
@@ -57,35 +57,28 @@ let
preDist = ''
make install docdir=$out/share/doc/nix makefiles=doc/manual/local.mk
-
- make doc/manual/manual.pdf
- cp doc/manual/manual.pdf $out/manual.pdf
-
- # The PDF containes filenames of included graphics (see
- # http://www.tug.org/pipermail/pdftex/2007-August/007290.html).
- # This causes a retained dependency on dblatex, which Hydra
- # doesn't like (the output of the tarball job is distributed
- # to Windows and Macs, so there should be no Linux binaries
- # in the closure).
- nuke-refs $out/manual.pdf
-
echo "doc manual $out/share/doc/nix/manual" >> $out/nix-support/hydra-build-products
- echo "doc-pdf manual $out/manual.pdf" >> $out/nix-support/hydra-build-products
'';
};
build = pkgs.lib.genAttrs systems (system:
- # FIXME: temporarily use a different branch for the Darwin build.
- with import (if system == "x86_64-darwin" then <nixpkgs-darwin> else <nixpkgs>) { inherit system; };
+ with import <nixpkgs> { inherit system; };
releaseTools.nixBuild {
name = "nix";
src = tarball;
buildInputs =
- [ curl perl bzip2 xz openssl pkgconfig sqlite boehmgc ]
+ [ curl perl bzip2 xz openssl pkgconfig sqlite boehmgc
+
+ (aws-sdk-cpp.override {
+ apis = ["s3"];
+ customMemoryManagement = false;
+ })
+
+ ]
++ lib.optional stdenv.isLinux libsodium;
configureFlags = ''
@@ -113,7 +106,7 @@ let
binaryTarball = pkgs.lib.genAttrs systems (system:
# FIXME: temporarily use a different branch for the Darwin build.
- with import (if system == "x86_64-darwin" then <nixpkgs-darwin> else <nixpkgs>) { inherit system; };
+ with import <nixpkgs> { inherit system; };
let
toplevel = builtins.getAttr system jobs.build;