aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/release.nix b/release.nix
index a98199258..c76966a1a 100644
--- a/release.nix
+++ b/release.nix
@@ -77,6 +77,9 @@ let
bzip2 xz brotli
openssl pkgconfig sqlite boehmgc
+ # Tests
+ git
+ mercurial
]
++ lib.optional stdenv.isLinux libseccomp
++ lib.optional (stdenv.isLinux || stdenv.isDarwin) libsodium
@@ -182,7 +185,7 @@ let
buildInputs =
[ curl bzip2 openssl pkgconfig sqlite xz libsodium libseccomp
# These are for "make check" only:
- graphviz libxml2 libxslt
+ graphviz libxml2 libxslt git mercurial
];
configureFlags = ''
@@ -193,7 +196,7 @@ let
doInstallCheck = true;
- lcovFilter = [ "*/boost/*" "*-tab.*" ];
+ lcovFilter = [ "*/boost/*" "*-tab.*" "*/nlohmann/*" "*/linenoise/*" ];
# We call `dot', and even though we just use it to
# syntax-check generated dot files, it still requires some
@@ -332,7 +335,7 @@ let
src = jobs.tarball;
diskImage = (diskImageFun vmTools.diskImageFuns)
{ extraPackages =
- [ "libsqlite3-dev" "libbz2-dev" "libcurl-dev" "libcurl3-nss" "libssl-dev" "liblzma-dev" "libseccomp-dev" "ncurses-bin" ]
+ [ "libsqlite3-dev" "libbz2-dev" "libcurl-dev" "libcurl3-nss" "libssl-dev" "liblzma-dev" "libseccomp-dev" ]
++ extraPackages; };
memSize = 1024;
meta.schedulingPriority = 50;