aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/release.nix b/release.nix
index 1e854a075..ec6bda995 100644
--- a/release.nix
+++ b/release.nix
@@ -219,6 +219,11 @@ let
nix = build.x86_64-linux; system = "x86_64-linux";
});
+ tests.setuid = pkgs.lib.genAttrs (pkgs.lib.filter (pkgs.lib.hasSuffix "-linux") systems) (system:
+ import ./tests/setuid.nix rec {
+ nix = build.${system}; inherit system;
+ });
+
tests.binaryTarball =
with import <nixpkgs> { system = "x86_64-linux"; };
vmTools.runInLinuxImage (runCommand "nix-binary-tarball-test"