aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/shell.nix b/shell.nix
index df0ad01df..425eb0a19 100644
--- a/shell.nix
+++ b/shell.nix
@@ -6,7 +6,7 @@ with import <nixpkgs> {};
name = "nix";
buildInputs =
- [ curl bison flex perl libxml2 libxslt
+ [ curl bison flex libxml2 libxslt
bzip2 xz brotli
pkgconfig sqlite libsodium boehmgc
docbook5 docbook5_xsl
@@ -16,14 +16,11 @@ with import <nixpkgs> {};
customMemoryManagement = false;
})
autoreconfHook
- perlPackages.DBDSQLite
];
configureFlags =
[ "--disable-init-state"
"--enable-gc"
- "--with-dbi=${perlPackages.DBI}/${perl.libPrefix}"
- "--with-dbd-sqlite=${perlPackages.DBDSQLite}/${perl.libPrefix}"
];
enableParallelBuilding = true;