aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/shell.nix b/shell.nix
index 8645d3602..c4e2a20f8 100644
--- a/shell.nix
+++ b/shell.nix
@@ -2,6 +2,8 @@
with import <nixpkgs> {};
+with import ./release-common.nix { inherit pkgs; };
+
(if useClang then clangStdenv else stdenv).mkDerivation {
name = "nix";
@@ -22,10 +24,7 @@ with import <nixpkgs> {};
perlPackages.DBDSQLite
];
- configureFlags =
- [ "--disable-init-state"
- "--enable-gc"
- ];
+ inherit configureFlags;
enableParallelBuilding = true;