aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index dd4484105..4c1608230 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,6 +1,8 @@
+{ useClang ? false }:
+
with import <nixpkgs> {};
-stdenv.mkDerivation {
+(if useClang then clangStdenv else stdenv).mkDerivation {
name = "nix";
buildInputs =