aboutsummaryrefslogtreecommitdiff
path: root/src/libexpr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libexpr/Makefile.am')
-rw-r--r--src/libexpr/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/libexpr/Makefile.am b/src/libexpr/Makefile.am
index 66a3008ed..7a361771e 100644
--- a/src/libexpr/Makefile.am
+++ b/src/libexpr/Makefile.am
@@ -12,11 +12,13 @@ AM_CFLAGS = \
# Parser generation.
+parser.o: parser-tab.h lexer-tab.h
+
parser-tab.c parser-tab.h: parser.y
- ../grammartest/inst/bin/bison -v -o parser-tab.c parser.y -d
+ $(bison) -v -o parser-tab.c parser.y -d
lexer-tab.c lexer-tab.h: lexer.l
- flex --outfile lexer-tab.c --header-file=lexer-tab.h lexer.l
+ $(flex) --outfile lexer-tab.c --header-file=lexer-tab.h lexer.l
CLEANFILES =