aboutsummaryrefslogtreecommitdiff
path: root/src/libexpr/flake/call-flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'src/libexpr/flake/call-flake.nix')
-rw-r--r--src/libexpr/flake/call-flake.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/libexpr/flake/call-flake.nix b/src/libexpr/flake/call-flake.nix
new file mode 100644
index 000000000..c59a0c75f
--- /dev/null
+++ b/src/libexpr/flake/call-flake.nix
@@ -0,0 +1,22 @@
+locks: rootSrc: rootSubdir:
+
+let
+
+ callFlake = sourceInfo: subdir: locks:
+ let
+ flake = import (sourceInfo + "/" + subdir + "/flake.nix");
+
+ inputs = builtins.mapAttrs (n: v:
+ if v.flake or true
+ then callFlake (fetchTree (removeAttrs v.locked ["dir"])) (v.locked.dir or "") v.inputs
+ else fetchTree v.locked) locks;
+
+ outputs = flake.outputs (inputs // { self = result; });
+
+ result = outputs // sourceInfo // { inherit inputs; inherit outputs; inherit sourceInfo; };
+ in
+ assert flake.edition == 201909;
+
+ result;
+
+in callFlake rootSrc rootSubdir (builtins.fromJSON locks).inputs