aboutsummaryrefslogtreecommitdiff
path: root/src/libstore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libstore/Makefile.am')
-rw-r--r--src/libstore/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libstore/Makefile.am b/src/libstore/Makefile.am
index 335655797..cb522d6bf 100644
--- a/src/libstore/Makefile.am
+++ b/src/libstore/Makefile.am
@@ -29,4 +29,4 @@ AM_CXXFLAGS = -Wall \
local-store.lo: schema.sql.hh
%.sql.hh: %.sql
- ../bin2c/bin2c schema < $< > $@ || (rm $@ && exit 1)
+ sed -e 's/"/\\"/g' -e 's/.*/"\0\\n"/' < $< > $@ || (rm $@ && exit 1)