aboutsummaryrefslogtreecommitdiff
path: root/src/libstore/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/libstore/meson.build')
-rw-r--r--src/libstore/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/libstore/meson.build b/src/libstore/meson.build
index f776e9621..7a129d22c 100644
--- a/src/libstore/meson.build
+++ b/src/libstore/meson.build
@@ -220,6 +220,7 @@ libstore = library(
nlohmann_json,
],
cpp_args : cpp_args,
+ cpp_pch : ['../pch/precompiled-headers.hh'],
install : true,
# FIXME(Qyriad): is this right?
install_rpath : libdir,
@@ -233,6 +234,16 @@ liblixstore = declare_dependency(
link_with : libstore,
)
+# FIXME: remove when https://git.lix.systems/lix-project/lix/issues/359 is fixed.
+if is_static
+ liblixstore_mstatic = declare_dependency(
+ include_directories : include_directories('.'),
+ link_whole : libstore,
+ )
+else
+ liblixstore_mstatic = liblixstore
+endif
+
# FIXME: not using the pkg-config module because it creates way too many deps
# while meson migration is in progress, and we want to not include boost here
configure_file(