aboutsummaryrefslogtreecommitdiff
path: root/src/libstore/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/libstore/meson.build')
-rw-r--r--src/libstore/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/libstore/meson.build b/src/libstore/meson.build
index e1c6c267a..0deedea42 100644
--- a/src/libstore/meson.build
+++ b/src/libstore/meson.build
@@ -66,6 +66,7 @@ libstore_sources = files(
'path-with-outputs.cc',
'path.cc',
'pathlocks.cc',
+ 'platform.cc',
'profiles.cc',
'realisation.cc',
'remote-fs-accessor.cc',
@@ -158,6 +159,14 @@ libstore_headers = files(
'worker-protocol.hh',
)
+if host_machine.system() == 'linux'
+ libstore_sources += files('platform/linux.cc')
+ libstore_headers += files('platform/linux.hh')
+else
+ libstore_sources += files('platform/fallback.cc')
+ libstore_headers += files('platform/fallback.hh')
+endif
+
# These variables (aside from LSOF) are created pseudo-dynamically, near the beginning of
# the top-level meson.build. Aside from prefix itself, each of these was
# made into an absolute path by joining it with prefix, unless it was already