aboutsummaryrefslogtreecommitdiff
path: root/src/nix/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/nix/meson.build')
-rw-r--r--src/nix/meson.build12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/nix/meson.build b/src/nix/meson.build
index 80223a390..cabdf0d2c 100644
--- a/src/nix/meson.build
+++ b/src/nix/meson.build
@@ -71,11 +71,21 @@ nix_sources = files(
'why-depends.cc',
)
+nix_headers = files(
+ 'daemon-command.hh',
+ 'hash-command.hh',
+ 'prefetch-command.hh',
+)
+
nix = executable(
'nix',
nix_sources,
+ legacy_sources,
nix_generated_headers,
- nix2_commands_sources,
+ nix_headers,
+ legacy_headers,
+ legacy_generated_headers,
+ include_directories : legacy_include_directories,
dependencies : [
libasanoptions,
liblixcmd,