aboutsummaryrefslogtreecommitdiff
path: root/tests/ca/text-hashed-output.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/ca/text-hashed-output.nix')
-rw-r--r--tests/ca/text-hashed-output.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/ca/text-hashed-output.nix b/tests/ca/text-hashed-output.nix
new file mode 100644
index 000000000..31a66dfa8
--- /dev/null
+++ b/tests/ca/text-hashed-output.nix
@@ -0,0 +1,29 @@
+with import ./config.nix;
+
+# A simple content-addressed derivation.
+# The derivation can be arbitrarily modified by passing a different `seed`,
+# but the output will always be the same
+rec {
+ root = mkDerivation {
+ name = "text-hashed-root";
+ buildCommand = ''
+ set -x
+ echo "Building a CA derivation"
+ mkdir -p $out
+ echo "Hello World" > $out/hello
+ '';
+ __contentAddressed = true;
+ outputHashMode = "recursive";
+ outputHashAlgo = "sha256";
+ };
+ dependent = mkDerivation {
+ name = "text-hashed-root.drv";
+ buildCommand = ''
+ echo "Copying the derivation"
+ cp ${builtins.unsafeDiscardOutputDependency root.drvPath} $out
+ '';
+ __contentAddressed = true;
+ outputHashMode = "text";
+ outputHashAlgo = "sha256";
+ };
+}