aboutsummaryrefslogtreecommitdiff
path: root/tests/check-refs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/check-refs.nix')
-rw-r--r--tests/check-refs.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/check-refs.nix b/tests/check-refs.nix
index 9d90b0920..a5e40c9e5 100644
--- a/tests/check-refs.nix
+++ b/tests/check-refs.nix
@@ -67,4 +67,13 @@ rec {
disallowedReferences = [test5];
};
+ test11 = makeTest 11 {
+ __structuredAttrs = true;
+ outputChecks.out = {
+ unsafeDiscardReferences = true;
+ allowedReferences = [];
+ };
+ buildCommand = ''echo ${dep} > "''${outputs[out]}"'';
+ };
+
}