aboutsummaryrefslogtreecommitdiff
path: root/tests/content-addressed.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/content-addressed.nix')
-rw-r--r--tests/content-addressed.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/content-addressed.nix b/tests/content-addressed.nix
new file mode 100644
index 000000000..586e4cba6
--- /dev/null
+++ b/tests/content-addressed.nix
@@ -0,0 +1,19 @@
+with import ./config.nix;
+
+{ seed ? 0 }:
+# A simple content-addressed derivation.
+# The derivation can be arbitrarily modified by passing a different `seed`,
+# but the output will always be the same
+mkDerivation {
+ name = "simple-content-addressed";
+ buildCommand = ''
+ set -x
+ echo "Building a CA derivation"
+ echo "The seed is ${toString seed}"
+ mkdir -p $out
+ echo "Hello World" > $out/hello
+ '';
+ __contentAddressed = true;
+ outputHashMode = "recursive";
+ outputHashAlgo = "sha256";
+}