aboutsummaryrefslogtreecommitdiff
path: root/tests/dependencies.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/dependencies.nix')
-rw-r--r--tests/dependencies.nix15
1 files changed, 12 insertions, 3 deletions
diff --git a/tests/dependencies.nix b/tests/dependencies.nix
index eca4b2964..e320d81c9 100644
--- a/tests/dependencies.nix
+++ b/tests/dependencies.nix
@@ -2,18 +2,27 @@ with import ./config.nix;
let {
+ input0 = mkDerivation {
+ name = "dependencies-input-0";
+ buildCommand = "mkdir $out; echo foo > $out/bar";
+ };
+
input1 = mkDerivation {
name = "dependencies-input-1";
- builder = ./dependencies.builder1.sh;
+ buildCommand = "mkdir $out; echo FOO > $out/foo";
};
input2 = mkDerivation {
name = "dependencies-input-2";
- builder = "${./dependencies.builder2.sh}";
+ buildCommand = ''
+ mkdir $out
+ echo BAR > $out/bar
+ echo ${input0} > $out/input0
+ '';
};
body = mkDerivation {
- name = "dependencies";
+ name = "dependencies-top";
builder = ./dependencies.builder0.sh + "/FOOBAR/../.";
input1 = input1 + "/.";
input2 = "${input2}/.";