aboutsummaryrefslogtreecommitdiff
path: root/tests/dependencies.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/dependencies.nix')
-rw-r--r--tests/dependencies.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/dependencies.nix b/tests/dependencies.nix
index 45aca1793..be1a7ae9a 100644
--- a/tests/dependencies.nix
+++ b/tests/dependencies.nix
@@ -1,3 +1,4 @@
+{ hashInvalidator ? "" }:
with import ./config.nix;
let {
@@ -21,6 +22,17 @@ let {
'';
};
+ fod_input = mkDerivation {
+ name = "fod-input";
+ buildCommand = ''
+ echo ${hashInvalidator}
+ echo FOD > $out
+ '';
+ outputHashMode = "flat";
+ outputHashAlgo = "sha256";
+ outputHash = "1dq9p0hnm1y75q2x40fws5887bq1r840hzdxak0a9djbwvx0b16d";
+ };
+
body = mkDerivation {
name = "dependencies-top";
builder = ./dependencies.builder0.sh + "/FOOBAR/../.";
@@ -29,6 +41,7 @@ let {
input1_drv = input1;
input2_drv = input2;
input0_drv = input0;
+ fod_input_drv = fod_input;
meta.description = "Random test package";
};