aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/extra-sandbox-profile.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/extra-sandbox-profile.nix')
-rw-r--r--tests/functional/extra-sandbox-profile.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/functional/extra-sandbox-profile.nix b/tests/functional/extra-sandbox-profile.nix
new file mode 100644
index 000000000..aa680b918
--- /dev/null
+++ b/tests/functional/extra-sandbox-profile.nix
@@ -0,0 +1,19 @@
+{ destFile, seed }:
+
+with import ./config.nix;
+
+mkDerivation {
+ name = "simple";
+ __sandboxProfile = ''
+ # Allow writing any file in the filesystem
+ (allow file*)
+ '';
+ inherit seed;
+ buildCommand = ''
+ (
+ set -x
+ touch ${destFile}
+ touch $out
+ )
+ '';
+}