aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/import-derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/import-derivation.nix')
-rw-r--r--tests/functional/import-derivation.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/functional/import-derivation.nix b/tests/functional/import-derivation.nix
new file mode 100644
index 000000000..44fa9a45d
--- /dev/null
+++ b/tests/functional/import-derivation.nix
@@ -0,0 +1,26 @@
+with import ./config.nix;
+
+let
+
+ bar = mkDerivation {
+ name = "bar";
+ builder = builtins.toFile "builder.sh"
+ ''
+ echo 'builtins.add 123 456' > $out
+ '';
+ };
+
+ value =
+ # Test that pathExists can check the existence of /nix/store paths
+ assert builtins.pathExists bar;
+ import bar;
+
+in
+
+mkDerivation {
+ name = "foo";
+ builder = builtins.toFile "builder.sh"
+ ''
+ echo -n FOO${toString value} > $out
+ '';
+}