aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-fail-overflowing-div.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-fail-overflowing-div.nix')
-rw-r--r--tests/functional/lang/eval-fail-overflowing-div.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-fail-overflowing-div.nix b/tests/functional/lang/eval-fail-overflowing-div.nix
new file mode 100644
index 000000000..44fbe9d7e
--- /dev/null
+++ b/tests/functional/lang/eval-fail-overflowing-div.nix
@@ -0,0 +1,7 @@
+let
+ # lol, this has to be written as an expression like this because negative
+ # numbers use unary negation rather than parsing directly, and 2**63 is out
+ # of range
+ intMin = -9223372036854775807 - 1;
+ b = -1;
+in builtins.seq intMin (builtins.seq b (intMin / b))