aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-attrs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-attrs.nix')
-rw-r--r--tests/functional/lang/eval-okay-attrs.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/tests/functional/lang/eval-okay-attrs.nix b/tests/functional/lang/eval-okay-attrs.nix
index 810b31a5d..7d5c04583 100644
--- a/tests/functional/lang/eval-okay-attrs.nix
+++ b/tests/functional/lang/eval-okay-attrs.nix
@@ -1,5 +1,8 @@
-let {
+let
as = { x = 123; y = 456; } // { z = 789; } // { z = 987; };
-
- body = if as ? a then as.a else assert as ? z; as.z;
-}
+in
+if as ? a then
+ as.a
+else
+ assert as ? z;
+ as.z