aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-delayed-with-inherit.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-delayed-with-inherit.nix')
-rw-r--r--tests/functional/lang/eval-okay-delayed-with-inherit.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-delayed-with-inherit.nix b/tests/functional/lang/eval-okay-delayed-with-inherit.nix
new file mode 100644
index 000000000..84b388c27
--- /dev/null
+++ b/tests/functional/lang/eval-okay-delayed-with-inherit.nix
@@ -0,0 +1,24 @@
+let
+ pkgs_ = with pkgs; {
+ a = derivation {
+ name = "a";
+ system = builtins.currentSystem;
+ builder = "/bin/sh";
+ args = [ "-c" "touch $out" ];
+ inherit b;
+ };
+
+ inherit b;
+ };
+
+ packageOverrides = p: {
+ b = derivation {
+ name = "b-overridden";
+ system = builtins.currentSystem;
+ builder = "/bin/sh";
+ args = [ "-c" "touch $out" ];
+ };
+ };
+
+ pkgs = pkgs_ // (packageOverrides pkgs_);
+in pkgs.a.b.name