aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-regex-match.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-regex-match.nix')
-rw-r--r--tests/functional/lang/eval-okay-regex-match.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-regex-match.nix b/tests/functional/lang/eval-okay-regex-match.nix
new file mode 100644
index 000000000..273e25907
--- /dev/null
+++ b/tests/functional/lang/eval-okay-regex-match.nix
@@ -0,0 +1,29 @@
+with builtins;
+
+let
+
+ matches = pat: s: match pat s != null;
+
+ splitFN = match "((.*)/)?([^/]*)\\.(nix|cc)";
+
+in
+
+assert matches "foobar" "foobar";
+assert matches "fo*" "f";
+assert !matches "fo+" "f";
+assert matches "fo*" "fo";
+assert matches "fo*" "foo";
+assert matches "fo+" "foo";
+assert matches "fo{1,2}" "foo";
+assert !matches "fo{1,2}" "fooo";
+assert !matches "fo*" "foobar";
+assert matches "[[:space:]]+([^[:space:]]+)[[:space:]]+" " foo ";
+assert !matches "[[:space:]]+([[:upper:]]+)[[:space:]]+" " foo ";
+
+assert match "(.*)\\.nix" "foobar.nix" == [ "foobar" ];
+assert match "[[:space:]]+([[:upper:]]+)[[:space:]]+" " FOO " == [ "FOO" ];
+
+assert splitFN "/path/to/foobar.nix" == [ "/path/to/" "/path/to" "foobar" "nix" ];
+assert splitFN "foobar.cc" == [ null null "foobar" "cc" ];
+
+true