aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-string.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-string.nix')
-rw-r--r--tests/functional/lang/eval-okay-string.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-string.nix b/tests/functional/lang/eval-okay-string.nix
new file mode 100644
index 000000000..47cc989ad
--- /dev/null
+++ b/tests/functional/lang/eval-okay-string.nix
@@ -0,0 +1,12 @@
+"foo" + "bar"
+ + toString (/a/b + /c/d)
+ + toString (/foo/bar + "/../xyzzy/." + "/foo.txt")
+ + ("/../foo" + toString /x/y)
+ + "escape: \"quote\" \n \\"
+ + "end
+of
+line"
+ + "foo${if true then "b${"a" + "r"}" else "xyzzy"}blaat"
+ + "foo$bar"
+ + "$\"$\""
+ + "$"