aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/shell.shebang.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/shell.shebang.nix')
-rwxr-xr-xtests/functional/shell.shebang.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/functional/shell.shebang.nix b/tests/functional/shell.shebang.nix
new file mode 100755
index 000000000..08e43d53c
--- /dev/null
+++ b/tests/functional/shell.shebang.nix
@@ -0,0 +1,10 @@
+#! @ENV_PROG@ nix-shell
+#! nix-shell -I nixpkgs=shell.nix --no-substitute
+#! nix-shell --argstr s1 'foo "bar" \baz'"'"'qux' --argstr s2 "foo 'bar' \"\baz" --argstr s3 \foo\ bar\'baz --argstr s4 ''
+#! nix-shell shell.shebang.nix --command true
+{ s1, s2, s3, s4 }:
+assert s1 == ''foo "bar" \baz'qux'';
+assert s2 == "foo 'bar' \"baz";
+assert s3 == "foo bar'baz";
+assert s4 == "";
+(import <nixpkgs> {}).runCommand "nix-shell" {} ""