aboutsummaryrefslogtreecommitdiff
path: root/tests/installer/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/installer/default.nix')
-rw-r--r--tests/installer/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/installer/default.nix b/tests/installer/default.nix
index 9b2a34bdb..d0707018f 100644
--- a/tests/installer/default.nix
+++ b/tests/installer/default.nix
@@ -146,7 +146,7 @@ let
echo "Testing Nix installation..."
# FIXME: should update ~/.bashrc.
- $ssh "
+ $ssh <<EOF
set -ex
# FIXME: get rid of this; ideally ssh should just work.
@@ -157,7 +157,10 @@ let
nix-env --version
nix --extra-experimental-features nix-command store ping
- "
+
+ out=\$(nix-build --no-substitute -E 'derivation { name = "foo"; system = "x86_64-linux"; builder = "/bin/sh"; args = ["-c" "echo foobar > \$out"]; }')
+ [[ \$(cat \$out) = foobar ]]
+ EOF
echo "Done!"
touch $out