aboutsummaryrefslogtreecommitdiff
path: root/tests/lang/eval-okay-foldlStrict-lazy-initial-accumulator.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/eval-okay-foldlStrict-lazy-initial-accumulator.nix')
-rw-r--r--tests/lang/eval-okay-foldlStrict-lazy-initial-accumulator.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-foldlStrict-lazy-initial-accumulator.nix b/tests/lang/eval-okay-foldlStrict-lazy-initial-accumulator.nix
new file mode 100644
index 000000000..abcd5366a
--- /dev/null
+++ b/tests/lang/eval-okay-foldlStrict-lazy-initial-accumulator.nix
@@ -0,0 +1,6 @@
+# Checks that the nul value for the accumulator is not forced unconditionally.
+# Some languages provide a foldl' that is strict in this argument, but Nix does not.
+builtins.foldl'
+ (_: x: x)
+ (throw "This is never forced")
+ [ "but the results of applying op are" 42 ]