aboutsummaryrefslogtreecommitdiff
path: root/tests/lang/eval-okay-listToAttrs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/eval-okay-listToAttrs.nix')
-rw-r--r--tests/lang/eval-okay-listToAttrs.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-listToAttrs.nix b/tests/lang/eval-okay-listToAttrs.nix
new file mode 100644
index 000000000..f5eae92cc
--- /dev/null
+++ b/tests/lang/eval-okay-listToAttrs.nix
@@ -0,0 +1,8 @@
+# this test shows how to use listToAttrs and that evaluation is still lazy (throw isn't called)
+let
+ asi = attr: value : { inherit attr value; };
+ list = [ ( asi "a" "A" ) ( asi "b" "B" ) ];
+ a = builtins.listToAttrs list;
+ b = builtins.listToAttrs ( list ++ list );
+ r = builtins.listToAttrs [ (asi "result" [ a b ]) ( asi "throw" (throw "this should not be thrown")) ];
+in r.result