aboutsummaryrefslogtreecommitdiff
path: root/tests/lang/eval-okay-zipAttrsWith.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/eval-okay-zipAttrsWith.nix')
-rw-r--r--tests/lang/eval-okay-zipAttrsWith.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-zipAttrsWith.nix b/tests/lang/eval-okay-zipAttrsWith.nix
new file mode 100644
index 000000000..877d4e5fa
--- /dev/null
+++ b/tests/lang/eval-okay-zipAttrsWith.nix
@@ -0,0 +1,9 @@
+with import ./lib.nix;
+
+let
+ str = builtins.hashString "sha256" "test";
+in
+builtins.zipAttrsWith
+ (n: v: { inherit n v; })
+ (map (n: { ${builtins.substring n 1 str} = n; })
+ (range 0 31))