aboutsummaryrefslogtreecommitdiff
path: root/tests/linux-sandbox-cert-test.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/linux-sandbox-cert-test.nix')
-rw-r--r--tests/linux-sandbox-cert-test.nix45
1 files changed, 23 insertions, 22 deletions
diff --git a/tests/linux-sandbox-cert-test.nix b/tests/linux-sandbox-cert-test.nix
index 2b86dad2e..2fc083ea9 100644
--- a/tests/linux-sandbox-cert-test.nix
+++ b/tests/linux-sandbox-cert-test.nix
@@ -1,29 +1,30 @@
-{ fixed-output }:
+{ mode }:
with import ./config.nix;
-mkDerivation ({
- name = "ssl-export";
- buildCommand = ''
- # Add some indirection, otherwise grepping into the debug output finds the string.
- report () { echo CERT_$1_IN_SANDBOX; }
+mkDerivation (
+ {
+ name = "ssl-export";
+ buildCommand = ''
+ # Add some indirection, otherwise grepping into the debug output finds the string.
+ report () { echo CERT_$1_IN_SANDBOX; }
- if [ -f /etc/ssl/certs/ca-certificates.crt ]; then
- content=$(</etc/ssl/certs/ca-certificates.crt)
- if [ "$content" == CERT_CONTENT ]; then
- report present
+ if [ -f /etc/ssl/certs/ca-certificates.crt ]; then
+ content=$(</etc/ssl/certs/ca-certificates.crt)
+ if [ "$content" == CERT_CONTENT ]; then
+ report present
+ fi
+ else
+ report missing
fi
- else
- report missing
- fi
- # Always fail, because we do not want to bother with fixed-output
- # derivations being cached, and do not want to compute the right hash.
- false;
- '';
-} // (
- if fixed-output == "fixed-output"
- then { outputHash = "sha256:0000000000000000000000000000000000000000000000000000000000000000"; }
- else { }
-))
+ # Always fail, because we do not want to bother with fixed-output
+ # derivations being cached, and do not want to compute the right hash.
+ false;
+ '';
+ } // {
+ fixed-output = { outputHash = "sha256:0000000000000000000000000000000000000000000000000000000000000000"; };
+ normal = { };
+ }.${mode}
+)