aboutsummaryrefslogtreecommitdiff
path: root/tests/modules/attrsOf-lazy-check.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/modules/attrsOf-lazy-check.nix')
-rw-r--r--tests/modules/attrsOf-lazy-check.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/modules/attrsOf-lazy-check.nix b/tests/modules/attrsOf-lazy-check.nix
new file mode 100644
index 000000000..ec5b418b1
--- /dev/null
+++ b/tests/modules/attrsOf-lazy-check.nix
@@ -0,0 +1,7 @@
+{ lib, config, ... }: {
+ options.isLazy = lib.mkOption {
+ default = ! config.value ? foo;
+ };
+
+ config.value.bar = throw "is not lazy";
+}