aboutsummaryrefslogtreecommitdiff
path: root/tests/modules/declare-set.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/modules/declare-set.nix')
-rw-r--r--tests/modules/declare-set.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/modules/declare-set.nix b/tests/modules/declare-set.nix
new file mode 100644
index 000000000..853418531
--- /dev/null
+++ b/tests/modules/declare-set.nix
@@ -0,0 +1,12 @@
+{ lib, ... }:
+
+{
+ options.set = lib.mkOption {
+ default = { };
+ example = { a = 1; };
+ type = lib.types.attrsOf lib.types.int;
+ description = ''
+ Some descriptive text
+ '';
+ };
+}