aboutsummaryrefslogtreecommitdiff
path: root/tests/modules/declare-submoduleWith-noshorthand.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/modules/declare-submoduleWith-noshorthand.nix')
-rw-r--r--tests/modules/declare-submoduleWith-noshorthand.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/modules/declare-submoduleWith-noshorthand.nix b/tests/modules/declare-submoduleWith-noshorthand.nix
new file mode 100644
index 000000000..af3b4ba47
--- /dev/null
+++ b/tests/modules/declare-submoduleWith-noshorthand.nix
@@ -0,0 +1,13 @@
+{ lib, ... }: let
+ sub.options.config = lib.mkOption {
+ type = lib.types.bool;
+ default = false;
+ };
+in {
+ options.submodule = lib.mkOption {
+ type = lib.types.submoduleWith {
+ modules = [ sub ];
+ };
+ default = {};
+ };
+}