aboutsummaryrefslogtreecommitdiff
path: root/tests/nix-build-examples.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/nix-build-examples.nix')
-rw-r--r--tests/nix-build-examples.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/nix-build-examples.nix b/tests/nix-build-examples.nix
new file mode 100644
index 000000000..e54dbbf62
--- /dev/null
+++ b/tests/nix-build-examples.nix
@@ -0,0 +1,33 @@
+with import ./config.nix;
+
+rec {
+
+ input0 = mkDerivation {
+ name = "dependencies-input-0";
+ buildCommand = "mkdir $out; echo foo > $out/bar";
+ };
+
+ input1 = mkDerivation {
+ name = "dependencies-input-1";
+ buildCommand = "mkdir $out; echo FOO > $out/foo";
+ };
+
+ input2 = mkDerivation {
+ name = "dependencies-input-2";
+ buildCommand = ''
+ mkdir $out
+ echo BAR > $out/bar
+ echo ${input0} > $out/input0
+ '';
+ };
+
+ body = mkDerivation {
+ name = "dependencies-top";
+ builder = ./dependencies.builder0.sh + "/FOOBAR/../.";
+ input1 = input1 + "/.";
+ input2 = "${input2}/.";
+ input1_drv = input1;
+ meta.description = "Random test package";
+ };
+
+}